centos7.4yum错误

1. 首先删除redhat原有的yum

  1.  

    rpm -aq | grep yum | xargs rpm -e
    –nodeps

  2.  

    rpm -aq | grep python-iniparse | xargs rpm
    -e –nodeps

    查看是否已经卸载完成:

  1.  

    rpm -aq | grep yum

  2.  

    rpm -aq | grep
    python-iniparse

1.删除原有的yum
rpm -aq|grep yum|xargs rpm -e –nodeps

引言:由于RHEL的yum在线更新是收费的,如果没有注册的话是不能使用的,即不能在线安装软件。在这种情况下,想使用RHEL系统,还想用yum源来在线安装软件,有没有办法?答案是有办法,请往下看!

2. 下载yum安装包

  1.  wget

  2.  wget

  3.  wget

  4.  wget

  5. wget

2.下载yum安装文件
(若没有此包,可以去阿里镜像或网易镜像找到包名一样的下下来即可)
wget
http://mirrors.163.com/centos/7/os/x86_64/Packages/yum-3.4.3-150.el7.centos.noarch.rpm
wget
http://mirrors.163.com/centos/7/os/x86_64/Packages/yum-metadata-parser-1.1.4-10.el7.x86_64.rpm
wget
http://mirrors.163.com/centos/7/os/x86_64/Packages/yum-plugin-fastestmirror-1.1.31-40.el7.noarch.rpm
wget
http://mirrors.163.com/centos/7/os/x86_64/Packages/python-iniparse-0.4-9.el7.noarch.rpm

1、删除RHEL原有的yum
            rpm -aq|grep yum|xargs rpm -e –nodeps  #删除

先安装python,在安装yum-metadata 最后两个yum一起安装。

3.进行安装yum
rpm -ivh python-iniparse-0.4-9.el7.noarch.rpm
rpm -ivh yum-metadata-parser-1.1.4-10.el7.x86_64.rpm
rpm -ivh yum-3.4.3-150.el7.centos.noarch.rpm rpm
yum-plugin-fastestmirror-1.1.31-40.el7.noarch.rpm
注意最后两个包必需同时安装,否则会相互依赖

2、下载新的yum安装包  #这里我们使用CentOS的yum源

3. 安装下载的rpm包

rpm -ivh python-iniparse-0.4-9.el7.noarch.rpm yum-metadata-parser-1.1.4-10.el7.x86_64.rpm yum-3.4.3-154.el7.centos.noarch.rpm yum-plugin-fastestmirror-1.1.31-42.el7.noarch.rpm

4.更新repo文件
进入 /etc/yum.repos.d文件夹下,
wget
http://mirrors.163.com/.help/CentOS7-Base-163.repo
删除原来的配置文件 rm -rf CentOS-Base.repo
修改新配置文件名 mv CentOS7-Base-163.repo CentOS7-Base.repo

  
wget 
       
 wget 
        
wget 
       
 wget 

You can leave a response, or trackback from your own site.

Leave a Reply

网站地图xml地图